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From raw data to useful insights
Have you ever wondered how some people make sense of large 
sets of numbers, turning them into clear, useful data and insights? 
Imagine having the power to organize, analyze, and visualize data 
like a pro. What if you could use spreadsheets to solve real 
problems and tell stories with numbers?

Skills and Pathways: Spreadsheets with Microsoft® Excel guides 
you from managing rows and columns to using complex functions 
for data analysis. You’ll learn how to create charts, work with tables, 
and use data modeling to predict outcomes—all with practical 
examples that help make data analysis easy.

By the end, you’ll not only feel confident in your spreadsheet skills, 
but you’ll also be prepared to earn a credential that shows you 
know how to turn data into meaningful insights—ready to take on 
any challenge with clarity and precision.
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Key Features
> An innovative approach to building digital competencies, developed by expert educators.
> Curriculum aligns with the latest industry standards, preparing students for certifications

and future careers.
> Well-defined learning goals and hands-on, applicable digital skills.

Each unit offers 
straightforward explanations 
and contemporary examples, 
making technology concepts 
accessible and relevant.

Every unit includes a 
variety of tasks and 
activities designed to help 
students build essential 
digital competencies.

Projects and exercises 
throughout the course reinforce 
students' understanding and 
practical application of digital 
skills in real-world scenarios.

Each unit organizes key terms 
that are crucial for digital literacy, 
equipping students for today’s 
technology-driven workplace.

Students learn about 
platform diversity 
expanding their digital 
toolkit and adaptability.
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Managing numbers and data is a skill that can help in many aspects of life, from 
tracking expenses to organizing information for school projects. This unit 
focuses on how to use spreadsheets to organize data, make calculations, and 
present information clearly using charts and graphs.

1 U N I T  1

�Working with numbers

Learning Objectives
In this unit, you will:

> �use spreadsheets to organize and analyze data.

> identify the basic components of Excel, including cells, rows, columns, and
worksheets, and how to enter and manipulate data.

> recognize the importance of formatting for clear data presentation and use
advanced tools like currency and date formats.

> enhance data presentation with techniques like merging cells, aligning text,
and applying borders and colors.

> use Excel formulas for basic calculations like addition, subtraction,
multiplication, and division.

> automate calculations using functions and apply formulas across multiple
cells with AutoFill.

> use the IF function and logical functions like AND and OR for conditional
calculations and data classification.

> create different types of charts in Excel and choose the right one for your
data.

> customize charts by adjusting titles, axes, and colors.

Tools
> �Microsoft Excel
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In the past, people used to make calculations by hand on paper and mistakes were common. Then, 
calculators came along and minimized the mistakes. However, it was very difficult and time-consuming 
to deal with large amounts of information, especially for businesses. Today, thanks to spreadsheets, all 
these are problems of the past.

But what is a spreadsheet? It’s like a large sheet of paper with lots of small boxes. People and 
businesses use spreadsheets mainly for organizing information and the computer does the rest, fast 
and accurately. Spreadsheets also help analyze information and produce charts. This is very useful.

Microsoft Excel is a spreadsheet program that imitates a paper spreadsheet. In Microsoft Excel, the 
primary document that is used to store and work with data is called a worksheet. Worksheets can be 
stored in a file, called a workbook.

Don’t forget the 
Zoom slider.

History
The first spreadsheet program for computers was VisiCalc. It was created by Dan Bricklin and Bob 
Frankston in 1979 and it was the first program that turned the microcomputer from a hobby into a 
serious business tool.

All programs in the 
Microsoft Office suite share 

the same user interface: 
tabs, buttons, and controls 

are in the same place.

The Formula bar allows 
you to type formulas. You 

can do that in the cells, too, 
but here you have more 

space to edit your formulas.

Microsoft Excel’s default file name is 
Book. This is because sometimes, in 
a single file, you want to have more 

than one table. It gives you this 
option through worksheets.

L E S S O N  1

Rows and columns
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Rows and columns
A worksheet is a grid consisting of cells arranged in rows and columns, where data is entered. A new 
worksheet can be opened to explore its features.

This is a cell.

A selected sequence of 
cells is usually written like 
this, A1:C2, which means 

from cell A1 to cell C2. 
Individual selected cells 
are written, A1,B2,C3, 

which means cells A1 and 
B2 and C3.

Each cell has a unique 
name, consisting of the 

column letter and the row 
number (e.g., D6).

There is always the name 
of the active cell in the 
top left corner of the 

worksheet in the  
Name Box.

This is a row. Each row 
has a number (1, 2, ...) on 
the left-hand side. These 
numbers are the names 

of the rows.

This is a column. Each 
column has a capital 

letter (A, B, ...) on the top. 
These letters are the 

names of the columns.

Smart Tip
Depending on the Regional settings, to quickly locate and select specific cells, the cell references 
are written with a semicolon between them in the Name Box, e.g., A1;B2;C3.

When you click a cell, it 
becomes active and its 

border becomes thicker.
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Insert text and numbers
Entering numbers and text into a worksheet involves clicking on a cell, typing, and then moving to 
another one. Microsoft Excel treats cells with numbers differently from cells with text. If both text and 
numbers are typed into a cell, Excel treats the cell as if it contains only text.

Change column width
If text cannot fit into a cell, only part of the text will be visible on the screen. However, the rest of the 
text is not lost. To view the entire text, the column width can be adjusted (resized).

To add text:

> Open a new worksheet.
> Click cell A1 and type the

word "Sports". 1

> Press  to go to B1 and
type the word "Saturday". 2

> Press  to go to C1 and
type the word "Sunday". 3

> Click cell A2 and type the
word "Jogging" and then
click A3 and type
"Cycling". 4

> Now in cell B2 type "30", in
B3 type "35", in C2 type
"30", and in C3 type "40". 5

Any text you type is left-justified 
and all numbers are right-justified. 

If you want to 
add text to a 
cell, double-

click it, or click 
the formula bar 
and start typing.

1 2 3

5
4

To change the column 
width:

> Point to the right side of
the column you want to
resize. 1

> Your cursor will change
into a double arrow pointer
with a vertical line. 2

> Click, hold and move the
mouse to the left or to the
right to change the width
of the column. 3

1 2

3
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To adjust a column’s 
width to fit its cells’ 
contents:

> Click a cell that you
want to make wider so it
fits your word/phrase. 1

> On the Home tab, in the
Cells group, click
Format. 2

> Click AutoFit Column
Width. 3

> The column will
automatically adjust to
the width of the text in
the cell. 4

1
3

2

4

Change row height
To change the height of a row, the same technique used for adjusting column width can be applied. It is 
also possible to change the height of multiple rows simultaneously.

To change the size of multiple 
rows:

> Select the rows whose height
you want to change, drag by
clicking the row numbers,
e.g., from row 2 to 3. 1

> Point between two of the row
headers that you selected.
Your cursor will change into a
double arrow pointer with a
horizontal line. 2

> Click, hold and move the
mouse up or down to change
the height of all the selected
rows simultaneously. 3

1

2

3
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To insert a new row, you 
will follow similar steps:

>	 Right-click the header of 
a row, e.g., row 1. 1

>	 From the drop-down 
menu click Insert. 2

>	 A new row will be 
inserted. 3

>	 Let’s add a title. Click 
cell A1 and type "My 
fitness schedule". 4

2

1

Insert columns and rows
Additional columns or rows can be added as needed. Similar to working with a table in Microsoft Word, 
rows and columns can be inserted anytime and anywhere within the worksheet. For example, to add 
the day "Friday" between "Sports" and "Saturday", simply insert a new column in the desired location.

To insert a new column:

>	 Right-click the header of a 
column, e.g., column B. 1

>	 From the drop-down menu 
click Insert. 2

>	 A new column will be 
inserted next to column A. 3

>	 Type the word "Friday" in cell 
B1, the number "15" in cell 
B2, and "20" in cell B3. 4

If you want to automatically insert more than one 
row or column, simply select the number of rows or 
columns you want to add. E.g., if you want to insert 

two columns next to column C, select columns D 
and E, right-click and select Insert. Two new 

columns will be added next to column C.

4

4

3

1

2

3
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To merge cells:

>	 Select the cells from A1 
to D1. 1

>	 On the Home tab, in the 
Alignment group, click 
Merge & Center. 2

>	 Microsoft Excel will 
automatically merge 
these cells and put the 
text in the center. 3

Wrap text
For long text that doesn't require a wider column, a multiline cell can be used. The text will wrap to the 
next line and continue wrapping until all of it is displayed correctly. Additionally, wrapped text 
automatically adjusts the row height to accommodate the content.

Merge cells
A good title will describe your data in a 
better way. To create a title above your 
columns, you can combine or "merge" 
two or more cells and make a longer cell.

To wrap text:

>	 Click cell A1. 1

>	 On the Home tab, in the 
Alignment group, click 
the Wrap Text button. 2

>	 Your text will 
automatically wrap to fit 
correctly in the cell. 3

Add Worksheet 
You may have noticed that at the bottom of the 
window there is a tab labeled Sheet1. Sometimes 
you need to have more than one table in the 
same book. That’s why you have this option. You 
can add or delete a worksheet or even rename it 
according to its content or purpose. 

To insert a new worksheet into the 
same file, click the (+) New sheet icon.

2

1

3

1

2

3
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Now that you know how to format a table, finish the job. Try 
to format the table as you like. Keep in mind that after you 

apply any format, you may need to change the width and the 
height of your rows and columns or apply new borders, etc.

Simple formatting
Occasionally, tables need to be adjusted for better readability or to highlight specific data, particularly 
with numbers. This is where formatting comes in. To apply different formats, the same method used in 
Microsoft Word can be applied. The buttons are similar, and it’s important to first select the data before 
applying the format.

To rename a worksheet:

> Double-click or
right-click Sheet1 and
click Rename. 1

> Type the name you
want, e.g., "Fitness
schedule" and press

. 2

Delete a 
worksheet.

1

2

Create your weekly schedule with Microsoft Excel. Now you will never forget the tasks that you have to 
do. Don’t forget, a good program saves time!

Hands on!

Decrease the 
digits after the 
decimal point.

Align the text to 
the top, center, or 
bottom of the cell.

Change the 
type of the 

content.

Increase the 
digits after the 
decimal point.

This is the Font 
group. Use it to 

format your table 
in the same way as 
in Microsoft Word.

Align the 
text to the 
left, center, 
or right of 
the cell.

Apply a comma as a 
thousands’ separator 

and a period for 
decimals, to the 

content of the cell.

Apply a 
currency format 

to a cell.

Turn the 
content of the 

cell into a 
percentage.
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So far, a small table has been created and formatted 
for clarity. Next, the focus will shift to understanding 
the meaning of numbers and further formatting 
options. Some of the topics to explore include the 
difference between numbers and currency, and how 
to enter dates into a cell. 

The task will involve creating a grocery list, including 
the items to purchase, their quantities, and the cost 
of each product. After entering the data, the list will 
be formatted using advanced options.

Currency
Let’s start with the price. A typical use of Microsoft 
Excel is to gather data that has to do with money. In 
such cases, you need to change the numbers into a 
currency format. 

To apply a currency format:

> Select the cells you want, e.g.,
C4 to C9. 1

> On the Home tab, in the Number
group, from the Number Format
list, 2  click Currency. 3

> The format of your cells has
changed. 4

You can choose between Number, Currency, 
Accounting, and Percentage. Accounting 

aligns the values at the decimal point.

4

2

3

1

L E S S O N  2

Advanced formatting
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Date
Microsoft Excel offers a range 
of date formats to choose 
from, allowing for greater 
flexibility in how dates are 
displayed.

Merge cells, wrap text, 
and set alignment
The previous task was about 
how you can format data. All 
of these options are included 
in a single window.

To apply Date or Time:

>	 Select the cell that 
contains the date you 
want to format, e.g., A1. 1

>	 On the Home tab, in the 
Number group, click the 
Expand button. 2

>	 The Format Cells window 
will open. Click Date. 3

>	 In the Type list, 4  click 
the type you like and 
then click OK. 5

Not all countries use 
the same date format. 

Some put the day 
before the month.

The date must be in the format 
that your computer is set to.

5

2

1

3

4

To merge cells, wrap  
the text, and align it:

>	 Select the cells you want 
to merge, e.g.,  
A2 to D2. 1

>	 On the Home tab, in the 
Number group, click the 
Expand button. 2

>	 In the Format Cells 
window, click the 
Alignment tab. 3

>	 Select the Wrap text 4

and Merge cells check 
boxes. 5

>	 In the Horizontal list, click 
Center and in the Vertical 
list, click Center again. 6

>	 Click OK. 7

Keep in mind that through 
the Expand button you 
have more options like 
custom text orientation.

1

You can also change 
the indentation or the 
orientation of the text.

3

2

6

5
4

7

L E S S O N  2

Advanced formatting
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History
VisiCalc was the first spreadsheet program. Later, Lotus 1-2-3 made it easier to use spreadsheets and 
it added integrated charting and database capabilities. Lotus 1-2-3 established spreadsheet software 
as a data presentation package as well as a complex calculation tool.

Borders and shading
Table formatting involves borders and colors. You can use borders and shading to divide your data into 
groups or to make differences and similarities more noticeable.

To apply a border:

>	 Select the table, e.g., A2 
to D9. 1

>	 On the Home tab, in the 
Number group, click the 
Expand button. 2

>	 In the Format Cells 
window, click the  
Border tab. 3

>	 Select a border style, 
e.g., click Outline and 
then click Inside. 4

>	 In the Style 5  and 
Color 6  lists, click the 
line style and the color 
you like and then  
click OK. 7

1

2

4

7

5

6

3

Remember that you can 
apply borders to the Outline 
or the Inside of the table or 

you can choose different 
styles for each side.
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To apply colors:

>	 Select the table or the cell you want to format, 
e.g., the title in cell A2. 1

>	 On the Home tab, in the Number group, click the 
Expand button. 2  

>	 In the Format Cells window, click the Fill tab. 3

>	 Click the color you want 4  and click OK. 5

1

2

5

3

4
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Insert image
Similar to Microsoft Word, 
images can be inserted to 
enhance the appeal of a table. 
An image can be inserted from 
the Illustrations section, placed 
anywhere within the table, and 
formatted as needed. However, 
avoid using the Format tab for 
this process.

To insert an image:

>	 �On the Insert tab, in the 
Illustrations group, click 
Pictures 1  then point to 
Place over cells and click 
Online Pictures. 2  

>	 In the Online Pictures 
window, type a keyword 
or phrase in the search 
box and press . 3

>	 Select one of the images 4  
and click Insert. 5

>	 The image you chose will 
be automatically inserted 
in your worksheet. 6

6

2

1

3

4

5

Make your own grocery list. What do you usually buy from the supermarket?

Hands on!

To format an image:

>	 Right-click the image and 
then click Format 
Picture. 1

>	 You will find the Format 
Picture pane, where you 
can find many options to 
format the image, 2  e.g., 
you can use Size to 
change the size of the 
image. 3  

>	 Experiment to get the 
desired results. 

1

3
2
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Analyzing your country’s agriculture 

Gather information about the agricultural production of your country.

	> Fill in the table with all 
the useful information 
that you have gathered.

	> Go on the Internet and 
gather information about 
these two subjects: 
which types of 
argiculture products your 
country produces and 
which are the most 
popular ones. Use 
websites with relevant 
information.

	> It’s time for statistics. 
After you decide which 
products you are going to 
analyze, start to gather 
statistics on them.  
For example, find out 
how much of that product 
your country produces, in 
which months, etc.

29

Project
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	> After you’re done with 
your data, focus on 
the statistics. What are 
the total and average 
amounts of the 
products per month or 
per year, etc.

	> Don’t forget that there 
are no statistics without 
charts. Create different 
types of charts to 
compare all the data and 
provide a visual 
representation of what 
you have gathered so far.

	> Finally, don’t forget to 
format your table.

	> After you gather all the 
necessary information, 
put it on a worksheet. 
Open Microsoft Excel 
and try to organize your 
data. Arrange it in a way 
that you think makes 
your data easier to read.
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How confident are you in your ability to apply the following skills?

>	 Describing the basic components of a spreadsheet.

>	 Understanding how to enter and format data in Excel.

>	 Creating and formatting tables for clear data organization.

>	 Using different formatting options, number formats, and text alignments.

>	 Designing appealing spreadsheets using advanced formatting tools.

>	 Using basic arithmetic operators and formulas for calculations.

>	 Applying functions and AutoFill for efficient data management.

>	 Using the IF function and logical functions for conditional operations and data analysis.

>	 Identifying, creating, and customizing various charts for clear data presentation and 
selecting appropriate charts for different datasets. 

Key Terms
autofill

autofit

AVERAGE

axis

calculation

cell

chart

column

column width

criterion

currency

decimal

division

false

formula

formula bar

function

grid

IF

legend

MAX

merge

MIN

percentage

row

row height

spreadsheet

style

subtraction

SUM

true

worksheet

Wrap up
Take a moment to reflect on your progress.
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